6

I am trying to use the Spectrogram Annotation Module in PAMGuard (initially had this issue in v2.01.05 but was able to recreate in v2.02.01) to manually mark some harmonics that were incorrectly detected with the Whistle and Moan Detector, so that I can remove them in post processing.

I set up the Spectrogram Annotation Module by going to File > Add Modules ... > Utilities > Spectrogram Annotation. I left the name of the module as the default, "Spectrogram Annotation" and hit "Ok"

I have a User Display set up with the spectrogram, and I can draw a box on the spectrogram, but then it just disappears. I have tried right clicking after drawing the box, and hitting enter, but I cannot figure out how to get the box to stay and count as an annotation.

How can I save the manually drawn annotation box?

Screenshot showing  the set up User Display, and the ability to draw the red box, but as soon as I release my mouse it disappears

Please help!

2
  • 2
    Can you please specify the version of PAMguard you're using? (I imagine this marking annotation feature is consistent across versions, but in case it's not, it'd be handy to know.) thanks
    – Chloe
    Jul 1 at 12:53
  • 1
    @chloe thanks for the suggestion. Added it!
    – selene
    Jul 4 at 3:10

1 Answer 1

3

The issue is that I did not have "Mark Observers" settings configured properly.

To fix:

(1) Turn on marks and observers. Go to the "Display" menu on the top menu bar, select "Display marks and observers" and in the pop up window, check the box for Spectrogram Annotation for the Spectrogram Display panel where you want to draw the manual annotations. You can check both if you want to be able to add manual annotations in either panel. Now, when the red box is drawn, it will linger, and pressing enter saves the annotation.

Check the "Spectrogram Annotation" check box in the Display mark relationships settings

(2) Toggle display of marks on. Right-click on the spectrogram display panel where you want any manual annotations to be displayed. A pop up menu will appear, mouse down to "Spectrogram Annotation, Mark" and click to turn it on. Now, any saved annotations will appear as black boxes.

To change the appearance of the displayed marks, click the "settings wheel" to the left of the text which will bring up another pop up where the symbology can be changed (color, shape, line thickness, etc.)

Pop-up menu when right-clicking within a spectrogram panel Mark symbology options pop-up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.