4
$\begingroup$

Background: I'm working on a project using PAMGuard's Whistle and Moan Detector to find killer whale stereotyped calls in recordings from a SoundTrap hydrophone. I'm currently trying to figure out how to use PAMGuard Viewer Mode as part of this, since it appears that you can't scroll through the spectrogram in Normal Mode to see all the detections made.

I've set up the binary files and a SQLite database storage system for saving the detections in PAMGuard, and I've been able to open the database in SQLite studio to make sure that the detections data is being saved as part of the database file.

enter image description here

enter image description here

I've been trying to see the data in PAMGuard Viewer Mode according to the steps from an Ocean Science Analytics guide on the subject (at the bottom of this post), but after I load the files, nothing shows up. The database name is there, but it just says "no data" and nothing shows up on the datagrams. I've double-checked that the database is indeed not empty in SQLite (as seen above), and that the correct database and binary file locations are being linked here. I've made sure that the correct audio file is linked through Sound Acquistion in case that was an issue. I'm new to using PAMGuard overall, and I've reached the limits of my knowledge on this. enter image description here

enter image description here

enter image description here

What's the most likely issue here, and how could I fix it so that I could use Viewer Mode with my files?

The steps I'm referencing are from the Introduction to Sound Traps tutorial document accessed through this link under "SoundTrap Data Analysis". The guide itself is based on PAMGuard version 2.02.03b. https://www.oceanscienceanalytics.com/bioacoustic-resources enter image description here enter image description here

Thank you! I'd appreciate any help.

$\endgroup$
2
  • 1
    $\begingroup$ The problem may be related to the sound acquisition module. If you load the database as you have, go to 'settings' at the top, select 'sound acquisition' do you see a check box for 'Offline files'? Try checking that and then moving forward or backwards in your spectrogram view. You may still need to toggle the contours on but you should be seeing data in the spectrogram. $\endgroup$
    – selene
    Jun 20, 2023 at 0:14
  • 1
    $\begingroup$ Let me know what the status of that checkbox is and if that is unchecked and that fixes it then I can turn it into a full answer and explain how to show the contours. $\endgroup$
    – selene
    Jun 20, 2023 at 0:15

1 Answer 1

4
$\begingroup$

There's not really enough information in your post to diagnose whatever issue might be occurring here. It could an issue with Pamguard, it could be an issue with the Soundtrap or data files, or it could be a PEBCAK issue, but it's hard to say without more information.

That said, I've recommended the tutorial from OSA that you mentioned to several students, and they have all completed it successfully.

So, my recommendation would be to first ensure that you can follow the tutorial exactly before trying it with your own data. More specifically, this means using the same version of Pamguard as suggested in the tutorial, using the tutorial dataset they provide for free online, and following all the steps. Doing this should rule out inconsistencies across Pamguard versions (yes this can make a difference), since it should be a known working dataset. Once you've got the tutorial working with the tutorial dataset, then you can try to swap out the tutorial wav-files with your own Soundtrap recordings and test whether the problem is with your Soundtrap files.

Applying a very methodical, step-by-step, workflow/process with a troubleshooting mentality is very much 'the Pamguard way'. Good luck, and hope this helps.

$\endgroup$
1
  • $\begingroup$ Thank you for the further info, and yeah, that's likely the best approach. I'm taking a hiatus from this project at the moment, but when I return to it hopefully starting from scratch will lead to it working smoothly. I appreciate the guidance! $\endgroup$ Jul 5, 2023 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.