12

In PAMGuard Viewer Mode, my whistle contours have become decoupled from the spectrogram on the frequency axis. I think I've accidentally changed a setting as I referred back to screenshots from this exact dataset where the contours match the fundamental frequency contour (i.e. it isn't an issue with my whistle detection settings when I processed the data in PAMGuard, I think it's something I've accidentally changed in viewer mode).

Anyone know how to fix this, please?

enter image description here

1
  • If one of the answers below answers your question, please 'accept' the answer by checking the checkmark under the vote tally. See stackoverflow.com/help/someone-answers
    – Shannon
    Jul 21 at 17:05

1 Answer 1

11

The data are stored as FFT bin number, not the actual frequency. Perhaps that was a mistake, but it's how it is. If you change the FFT length and hop back to what it was when you processed the data, everything should line up again. You may need to restart PAMGuard after changing the settings.

1
  • Great- thanks Doug!
    – Laura P
    Jul 21 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.